IPv6 Freigabe auf eigenen Server nicht möglich

Hier können sich alle gegenseitig bei Fragen mit eigenen Endgeräten helfen. Eine Unterstützung durch das Supportteam gibt es hier nicht.

Moderatoren: Yusuf, Florian S., Sven

nerd0815
Junior - Member
Junior - Member
Beiträge: 14
Registriert: 21.09.2018, 14:52

IPv6 Freigabe auf eigenen Server nicht möglich

Beitragvon nerd0815 » 24.09.2018, 22:50

Hi

Freigaben über meine Fritzbox 7430 funktionieren bei mir leider nicht. Mein Vertrag ist der 100Mbit Privatkundenvertrag.

Hier ein paar Details zum Setup in meinem Netzwerk

    - Http-Server auf einem RaspberryPi3b+ in meinem Netzwerk
    - Der Pi hat eine IPv6 Adresse und die Seite ist über diese im lokalen Netzwerk erreichbar (mit folgender Syntax: "http://[xxxx-xxxx-xx...xx-xxxx]")
    - Diese IPv6 Adresse wurde von der Fritzbox zugeteilt. DHCPv6 ist aktiviert und verteilt vollständige IPv6 Adressen (also nicht nur den Prefix). Die IP meiner Fritzbox hat einen Präfix von "xxxx-...-xxxx/56". Der unter "Ipv6 Präfix" angezeigte Präfix der Fritzbox ist auch der Präfix der IPv6 Adresse von meinem Pi
    - Der Pi ist über Wlan verbunden, der erfolgreiche Zugriff erfolgt über Geräte aus Wlan und Lan.
    - Die IPv6 Freigabe ist eingerichtet (nur IPv6, also keine zusätzliches NAT für IPv4). Als "Adresse im Internet" wird die IPv6-Adresse, die von der FritzBox zugeteilt wurde, angezeigt
    (- Mit dem Update auf "FRITZ!OS: 06.83" sollte es nicht zu tun haben, die Freigabe habe ich vor 2 Tagen das erste mal erstellt und seitdem auf mehrere Varianten probiert und damit die Freigabe mehrfach neu erstellt)

Woran liegts?
Welche Einstellungen spielen noch ein Rolle oder könnten die erfolgreiche Freigabe verhindern?
Ich hatte den Eindruck, dass alle Anfragen im Internet mit dem Präfix meiner FritzBox an diese gehen sollten. Wieso werden diese dann nicht weitergeleitet?
Was kann ich analysieren um die Ursache zu finden?


Viele Grüße
Daniel

till1969
Aufsteiger
Aufsteiger
Beiträge: 358
Registriert: 19.02.2014, 11:06

Re: IPv6 Freigabe auf eigenen Server nicht möglich

Beitragvon till1969 » 25.09.2018, 09:11

Zuerst auf FritzOS 7.01 aktualisieren
DHCPv6-Server im Heimnetz: "Nur DNS-Server zuweisen" aktivieren

Bei der Freigabe des PI auch mal Ping6 freigeben, dann einen Ping Test machen:

Erst vom PC auf die 2001:.... des PI, wenns geht dann von extern:
https://centralops.net/co/Ping.aspx

Wenn der Ping geht, sollten auch andere Freigaben gehen ;)

nerd0815
Junior - Member
Junior - Member
Beiträge: 14
Registriert: 21.09.2018, 14:52

Re: IPv6 Freigabe auf eigenen Server nicht möglich

Beitragvon nerd0815 » 25.09.2018, 22:44

Danke schon mal für die Antwort!

- FritzOs 7.01 wird mir in der Oberfläche nicht zum Update angeboten. Wenn ich "Zustand analysieren" mache wird mir angezeigt: FRITZ!OS 06.83 ist aktuell

- Den DHCP habe ich auf "Nur Dns Server bereitstellen" umgestellt und Ping6 aktiviert.

- Die Seite ist cool, danke! Der Ping kommt nicht durch. Aber der Traceroute zeigt, dass das Problem sicher an der Fritzbox liegt. Das Traceroute bricht bei der Ip meiner FB ab.

Funktionieren IPv6 Freigaben vor FritzOS 7.xx nicht?

whitman
Aufsteiger
Aufsteiger
Beiträge: 65
Registriert: 20.11.2014, 19:10

Re: IPv6 Freigabe auf eigenen Server nicht möglich

Beitragvon whitman » 26.09.2018, 08:40

nerd0815 hat geschrieben:Funktionieren IPv6 Freigaben vor FritzOS 7.xx nicht?

Zumindest für die 7490 kann ich dies nicht bestätigen. Falls die Fritzbox von m-net ist, ist die 6.83 die aktuelle Version (siehe auch viewtopic.php?f=20&t=10990 ).

till1969
Aufsteiger
Aufsteiger
Beiträge: 358
Registriert: 19.02.2014, 11:06

Re: IPv6 Freigabe auf eigenen Server nicht möglich

Beitragvon till1969 » 26.09.2018, 08:58

nerd0815 hat geschrieben:Funktionieren IPv6 Freigaben vor FritzOS 7.xx nicht?

Durchaus möglich ;)

[moderiert: Inhalt gelöscht, da Verstoß gegen Nutzungsbedingungen]
Dieter hat geschrieben:Nutzungsbedingungen

...
11. Beiträge zu M-net Dienstleitungen
Beiträge, die eine Modifikation eines M-net Produktes bzw. einer M-net Dienstleistung beschreiben, die nicht der Leistungsbeschreibung bzw. der Geschäftsbedingung des jeweiligen Produktes entspricht oder aber die Umgehung von Passwörtern beschreiben, sind nicht erlaubt.
...

Benutzeravatar
Yusuf
Admin
Admin
Beiträge: 7578
Registriert: 23.11.2006, 15:22

Re: IPv6 Freigabe auf eigenen Server nicht möglich

Beitragvon Yusuf » 26.09.2018, 09:15

till1969 hat geschrieben:
nerd0815 hat geschrieben:Funktionieren IPv6 Freigaben vor FritzOS 7.xx nicht?

Durchaus möglich ;)

[gelöscht]


Das ist eine M-net Fritz!Box und würde somit eine Manipulation des Endgerätes sein. Wenn es kein M-net Gerät wäre, wäre auch ein Update über die grafische Oberfläche möglich.

Gruß,
Yusuf

nerd0815
Junior - Member
Junior - Member
Beiträge: 14
Registriert: 21.09.2018, 14:52

Re: IPv6 Freigabe auf eigenen Server nicht möglich

Beitragvon nerd0815 » 26.09.2018, 18:32

Hi Yusuf

Ich habe in einem anderen Thread gelesen, dass IPv4 Weiterleitungen "ignoriert" werden. Kann es sein, dass es ein Problem spezifisch der M-Net Fritzboxen ist?

Gibt es evtl. noch Einstellungen, die ich übersehen haben könnte?

Gibt es jemand der schon einmal erfolgreich eine Portfreigabe auf einer Mnet Fritzbox 7430 mit FritzOs6.81 eingerichtet hat?

Viele Grüße

PS:
Update
- Die von meinem Pi selbst zugewiesene IPv6 Adresse [<myprefix>:<ownAddressPart>] kommt bei einem Traceroute noch nicht einmal bei meiner Fritz an. Obwohl der selbe Prefix gesetzt ist. Woran liegt das? Das Traceroute hängt bei [2001:a60::89:702:1]. Wird das routen bei Mnet unter gewissen Voraussetzungen blockiert? Diese Adresse ist bei erfolgreichen Ping meiner Fritz immer der letzte Hop.
- Nach dem Deaktivieren von DHCPv6"ganze Adresse zuweisen" wird diese Adresse immer noch in der Geräteinformation angezeigt. Da diese aber nicht mehr zugewiesen ist, ist das Gerät nicht über diese erreichbar. Das scheint auf alle Fälle ein Bug in FritzOs6.81 zu sein.

till1969
Aufsteiger
Aufsteiger
Beiträge: 358
Registriert: 19.02.2014, 11:06

Re: IPv6 Freigabe auf eigenen Server nicht möglich

Beitragvon till1969 » 26.09.2018, 21:20

nerd0815 hat geschrieben:Kann es sein, dass es ein Problem spezifisch der M-Net Fritzboxen ist?

Nein, die M-Net Firmware ist identisch mit denen des AVM Servers ;)
Hab Dir eine PM geschrieben.

Hab gerade mal einen externen Ping6 auf eine Debian VM probiert, geht einwandfrei mit meiner 7362SL und 6.83.

Hast Du eine Firewall auf dem PI?
Ist der PI aus dem LAN mit der externen IPv6 anpingbar?
Funktioniert "ping6 google.de" auf dem PI?

nerd0815
Junior - Member
Junior - Member
Beiträge: 14
Registriert: 21.09.2018, 14:52

Re: IPv6 Freigabe auf eigenen Server nicht möglich

Beitragvon nerd0815 » 27.09.2018, 19:20

till1969 hat geschrieben:Hast Du eine Firewall auf dem PI?
Ist der PI aus dem LAN mit der externen IPv6 anpingbar?
Funktioniert "ping6 google.de" auf dem PI?

Nein
Ja, jetzt auch von extern
Ja
Wie gesagt lokal im Netzwerk funktioniert alles, auch über diese zugewiesene v6Adresse.


Update:
Nach mehrmaligem Dhcpv6 umstellen von "Nur Server zuweisen" auf "ganze Adresse zuweisen" und die Freigabe (de-)aktivieren kommt jetzt Ping und Traceroute durch. Die Portfreigabe auf :80 funktioniert aber immer noch nicht...

Ping kommt durch, Http nicht. Ich habe die Vermutung, dass allgemein TCP Pakete geblockt werden. Gibt es dafür Einstellungsmöglichkeiten? Ich habe noch keine gefunden...

till1969
Aufsteiger
Aufsteiger
Beiträge: 358
Registriert: 19.02.2014, 11:06

Re: IPv6 Freigabe auf eigenen Server nicht möglich

Beitragvon till1969 » 27.09.2018, 19:39

Wie testest Du denn den Port 80?
Funktioniert denn "telnet 2001:..... 80" im LAN?

nerd0815
Junior - Member
Junior - Member
Beiträge: 14
Registriert: 21.09.2018, 14:52

Re: IPv6 Freigabe auf eigenen Server nicht möglich

Beitragvon nerd0815 » 27.09.2018, 23:05

Ich teste mit dem Browser und einem deutschen Proxy. Parallel dazu mit Handy über mobile Daten.

Jetzt habe ich mal einen MyFritz Account eingerichtet und die MyFritz-Freigaben scheinen zu funktionieren. Jetzt habe ich langsam genug Zeit investiert, schade dass von Mnet keine Hilfe kam...

Danke Til!

PS:
Mein eigentliches Anliegen, die Ipv6 Freigabe, ist damit natürlich nicht gelöst und ich kann über meine Domain weiterhin nicht auf meine Server zugreifen. Durch die MyFritz-Freigabe habe ich jetzt nur allgemein die Möglichkeit von außen auf meine Server zu kommen. Aber keine zufriedenstellende Lösung, weil meine SSL-Zertifikate jetzt auf die myfritz Url ausgestellt werden müssen :|

whitman
Aufsteiger
Aufsteiger
Beiträge: 65
Registriert: 20.11.2014, 19:10

Re: IPv6 Freigabe auf eigenen Server nicht möglich

Beitragvon whitman » 28.09.2018, 09:02

nerd0815 hat geschrieben:Aber keine zufriedenstellende Lösung, weil meine SSL-Zertifikate jetzt auf die myfritz Url ausgestellt werden müssen :|

Warum das? Ist doch unabhängig von einander, man kann viele Domain auf eine IP und anderes herum.

MyFritz nutze ich auch, wegen der exteren IPv6 Adressauflösung. Wenige DynDns Dienste können IPv6 für Netze und die Fritz.box gibt nur seine eigene IPv6 weiter und nicht den Präfix :aerger
So läuft bei mir die domain.tld (mit entsprechenden Zertifikat) per cname auf server.sfihsdfuihsef.myfritz.net.

nerd0815
Junior - Member
Junior - Member
Beiträge: 14
Registriert: 21.09.2018, 14:52

Re: IPv6 Freigabe auf eigenen Server nicht möglich

Beitragvon nerd0815 » 30.09.2018, 18:02

Ok die Freigabe funktioniert jetzt. Das es so lange nicht funktioniert hat war wahrscheinlich eine Kombination aus mehreren Problemen / unerwarteten Verhaltensweisen:

- DNSv6 funktioniert bei Mnet-Fritzboxen nicht (viewtopic.php?f=10&t=12205&p=111731)
- Freigabe in der Fritzbox funktioniert erst nach mehrmaligem (de-)aktivieren / mit einiger Zeitverzögerung
- der IPv6 Prefix ändert sich regelmäßig (täglich?). Hatte immer nur eine begrenzte Zeit am Abend um das Problem zu analyisieren...

Mein funktionierendes Set an Einstellungen ist jetzt:
- DHCPv6 in der Fritzbox (unter Heimnetz/Heimnetzübersicht/Netzwerkeinstellungen/Ipv6Adressen) auf "DNS-Server, Präfix (IA_PD) und IPv6-Adresse (IA_NA) zuweisen"
- Freigaben für Http/Https mit myFritz UND noch mal als normale Portfreigabe in der Fritzbox
- Meine Domain leitet auf die myFritz Freigabe mit einem "CNAME" Eintrag weiter
- Jeder Client in einem Heimnetz mit Mnet-Fritzbox braucht eine eigene DNS Server Konfiguration mit eigenen (nicht Mnet) DNS Servern (zB http://1.1.1.1)


Zurück zu „Kunden helfen Kunden (eigene Endgeräte)“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast